sexta-feira, 21 de janeiro de 2011

Mega Post 2: FlightGear 1.9.0 e Bombable


Voando a muitos Knots, nessa segunda versão dos Mega Posts, vou falar sobre o FlightGear 1.9 para linux e sobre o Bombable, ou na tradução, bombardiável (ou seria bombável? XD).

1. FlightGear 1.9.0 para Linux

Por esses dias, meu PC se rebelou e não quis mais dar boot no meu Ubuntu. Fiquei muuuito nervoso pq tinha vários aviões convertidos para o FlightGear. Fui reinstalar o sistema, e depois de instalado, ví no gerenciador de atualizações (Sistema, Administração, Gerenciador de Atualizações) que estava disponível o Ubuntu 9.10, sendo que até então, eu usava o 9.04 com o FligthGear q eu supostamente achava ser o 1.9. Instalei a versão 9.10 do ubuntu, achei muito legal os efeitos gráficos, os gráficos, a tela de inicialização e etc. Mas assim que tava tudo ok, fui direto no Synaptic (Sistema, Administração,Gerenciador de pacotes Synaptic) instalar o FlightGear e vejo que a versão era a 1.9.0. Pensei logo que fosse o que eu usava, o do Cessna 172p com painel cinza e sem livrarias. Mas assim que instalei e rodei, ví que a tela do cessna estava diferente, o menu estava diferente, o som estava diferente e então o Cessna estava diferente! o 777-200ER vinha instalado (por isso eu postei um 777-200ER). Fiquei muito feliz e conclui que o que eu usava era o 1.0!!! Para quem não sabe, o 1.9 tem muitas melhorias, entre elas: melhores efeitos, neve caindo, boa parte dos aviões do 2.0 funcionam, vc não precisa mais converter as texturas pra ele não ficar vermelho e muitas outras. ai vai uma lista completa de mudanças da versão 1.0, que é a do Ubuntu 9.04 e inferiores, para a 1.9 (lista retirada do site oficial do FG):
    FlightGear 1.9.0 representa um fundamental rearranjo no código, incorporando mais de dois anos de desenvolvimento. Após terminar a versão 1.0.0 lançada em dezembro de 2007, a equipe de desenvolvimento do FlightGear tem dirigido a sua atenção total ao acabamento e revisão do código que já tinha sido iniciado em outubro de 2006. A atual versão 1.9.0 do FlightGear foi criada a partir da aclamada biblioteca OpenSceneGraph, expandindo, assim, amplamente as capacidades gráficas do FlightGear. Para fazer uso desta rica característica do FlightGear, a versão 2.7.3 do OpenSceneGraph é necessária (a versão 2.7.8 do OpenSceneGraph 2.7.8 é recomendada para evitar bugs na renderização ). A mudança para o OpenSceneGraph assinala um marco importante para o FlightGear, pois permite-nos fazer uso pleno das opções avançadas de renderização já disponíveis no OpenSceneGraph, tais como estatísticas na tela no modo de visão estereográfica, fácil definição de sistemas de câmeras para multi-telas, estatísticas na tela, modelos 3D do OpenSceneGraph nativos e muito mais.
    Embora as mudanças mais dramáticas no FlightGear estejam no código fonte, a versão mais recente oferece muitas novas características emocionantes não encontrados em nenhuma versão anterior. Alguns novas características em destaque incluem:
    As principais novidades e funcionalidades:
  • Grande revisão dos código gráficos. FlightGear 1.9.0 utiliza agora a biblioteca OpenSceneGraph
  • Fácil configuração de sistemas com vários monitores utilizando múltiplas "Câmeras" OpenSceneGraph dirigidas por uma única instância do FlightGear.
  • Carregador de modelos 3D multi-tarefa, que permite uma perfomance mais rápida
  • Novo sistema de partículas baseado em código de precipitação
  • Animações de partículas de fumaça, spray, fogo, etc configurável num arquivo XML
  • Nova configuração dinâmica de nuvens 3D
  • Animações de seleção, que permitem melhores instrumentos de painel clicáveis
  • Menu especifico na tela para multiplayer
  • Código de Inteligência Artificial pode gerar acrobacias aéreas
  • Em aeroportos selecionados, agora é possível iníciar em uma posição predefinida no estacionamento, como uma alternativa para começar a pista.
  • Suporte para veículos mais leves que o ar
  • Renderização baseada em Shader para árvores. Esta nova funcionalidade permite uma densidade arbórea maior, sem qualquer perda na taxa de quadros.
  • Suporte para texturas JPG e PNG
  • Um novo modo de comando multikey, em que vários cursos chaves podem ser combinados para formar um comando.
  • Edifícios detalhado em diversos aeroportos e grandes cidades do mundo
  • Cenário pode ser mantido atualizado por fazer download do repositório SVN usando o TerraSync
  • Mais de 200 aeronaves já estão disponíveis para download em separado.
    Melhorias no Código:
  • Melhoria nas Dinâmicas de Voo
  • Várias melhorias para animações
  • Melhoria no comportamento do taxiamento de aeronaves interativas.
  • Diversas melhorias na Interface Gráfica
  • Muitas melhorias no código do gerenciador de rotas do FlightGear.
  • Melhoria na gestão das pista
  • Melhoria no encapsulamento de Navaids
  • Melhoria na segurança de scripts nasal
  • Melhoria do comportamento de rádios VOR quando próximo de seu alcance máximo.
  • Displays Holográficos configuráveis
  • Melhorado o suporte de instrumentos GPS
  • Definição mais fácil de padrões de tráfego Interátivo
  • Melhoria na precisão das costas
Viram? Agora é so vc atualizar seu Ubuntu e instalar o FlightGear v1.9.0.

2.Bombable

Funcionando nas versões 1.9 e superiores, o Bombable é um conjunto de scripts que tornam o FlightGear mais realista e emocionante. Sua aeronave ao cair explode, fica saindo fumaça e fogo, se você ultrapassar o limite máximo de velocidade você vai danificando seu avião até cair e explodir, se você ultrapassar a força G você pode explofir, você pode se "divertir" nos cenários de AI, como por exemplo o SanFranWartHogInvasion, que são vários A-10 invadindo San Francisco e você pode derrubá-los com mísseis e metralhas e vê-los pegando fogo e caindo quando atingidos, você pode derrubar outros aviões de outros jogadores que tenham o Bombable, temos ainda o SanFranBayFerryInvasion que é a invasão de navios que você pode afundá-los. Emfim, dexa muito mais divertido e é ótimo para fazer guerras em rede (to querendo fazer uma!). Quem quiser baixar, clique aqui. Nesse link vc pode ver um vídeo de demonstração do Bombable.

Como instalar


Para instalar o Bombable, você precisa ter o FligthGear 1.9 ou superior.

Abra o terminal (Aplicativos, Acessórios, Terminal) e digite a seguinte sequência:

sudo su (e então a senha do seu PC)
cd ..
cd ..
cd usr/share/games/

Os próximos comandos só dê depois de terminar de baixar o pacote (e quando terminar, não feche o navegador), e se puder, desconecte a internet enquanto executa os próximos passos.

chmod -R 777 FligthGear

Então descompacte o pacote na pasta do FligthGear (usr/share/games/FlightGear).
Após descompactar, siga a sequência:

chmod -R 555 FlightGear
exit
fgfs --aircraft=c172p (esse comando vai abrir o FG só para vc fazer o teste pra ver se funciona)

após abrir o FG, decole seu Cessna e depois jogue ele contra o chão pra ver ele explodir! Se não der certo, faça tudo de novo. Se der, divirta-se!

Valeu por ler mais esse Mega Post. Pra quem quiser saber, sempre que eu estiver jogando FligthGear meu cod-nome eh Nemweb! Ateh o próximo post! Falow galera!